Skip to main content

OpenBSD 101 - Basic

I got 2 customer that using 2 FreeBSD box serving as their gateway. Both are installed squid to cache their web browsing for the network. It's time to upgrade both of the box, I thinking of using OpenBSD as a gateway to see how OpenBSD perform.

I'm working on my virtualbox to test before deploy and implement them :)

Basic networking for OpenBSD

IP Forwarding:

Permanenant:
#vi /etc/sysctl.conf

Change from:
#net.inet.ip.forwarding=1

To
net.inet.ip.forwarding=1

You can change it on the spot by issuing the command
#sysctl net.inet.ip.forwarding=1

But this will revert to default once you reboot the machine, use permanent then.

Setting up IP address :

File : /etc/hostname.em0 (depends on your network card)
Structure : type address netmask broadcast others

#vi /etc/hostname.em0

inet 10.0.0.1 255.255.255.0 NONE

Setting interface for DHCP

#vi /etc/hostname.em0

dhcp

http://www.openbsd.org/faq/faq6.html

Once done, restart the service

#sh /etc/netstart

Setting up package :

Set PKG_PATH

#export PKG_PATH=ftp://ftp.jaist.ac.jp/pub/OpenBSD/5.1/packages/`machine -a`

Get list of available ftp mirror that nearest for you

http://www.openbsd.org/ftp.html

how to install :

#pkg_add -i vim

i - interactive, you can choose from variety of package available.

Comments

Popular posts from this blog

Zenclouds October Promotion - Malaysia VPS Hosting

For those who are not familiar with what Zenclouds.com is , check this out : Zenclouds subsidiary of Art In Software Sdn Bhd is an industry-leading, privately virtual private server hosting and software services provider with headquarters in Malaysia. Since 2003, the company has provided businesses worldwide with reliable, high-capacity networks to host websites, email, business applications, video and other modern, rich-media content. Zenclouds evolve in one year of research and development mainly focus on Control Panel for managing virtual private server. Zenclouds integrate between Xen technologies and our own Control Panel to ease our customer managing multiple server with different Data Center with one control panel. Zenclouds integrates the industry's best technologies for each customer's specific need and delivers it as a service via the company's commitment and support. For this upcoming October you can win and own a brand new iPod Shuffle, Nano and Touch when y...

Warning Nuffnanger's!

Dear Nuffnangers, As you might already know, there are 2 different types of campaigns from Nuffnang: Metered (mCPM) Campaigns , which pay according to the number of visitors who see the ads; and Cost-Per-Click (CPC) campaigns, which pay bloggers based on the number of clicks generated on the ads. It has come to our attention that certain groups have been committing click fraud, which is defined as clicking on CPC advertisements intentionally just to generate earnings for a blog's owner. Do note that this act is an abuse of our Terms & Conditions under Section 6. Banner ads are only supposed to be clicked on if the viewer is interested to find out more about the advertising campaign, and not for the intention of earning extra money. Should this situation worsen, the frequency of ad campaigns might be significantly reduced as we'll only be able to sell ad spaces on blogs with no click fraud record. Our system is capable of tracking these illegal actions...

Python - Xen and libvirt

more function can be found in python dir libvirtclass.txt shell> find / -name libvirtclass.txt Generated Classes for libvir-python # # Global functions of the module # # functions from module libvirt open() openReadOnly() virEventRegisterImpl() virInitialize() # functions from module virterror virGetLastError() virResetLastError() # # Set of classes of the module # Class virDomain()     # functions from module libvirt     ID()     OSType()     XMLDesc()     attachDevice()     blockPeek()     connect()     coreDump()     create()     destroy()     detachDevice()     maxMemory()     maxVcpus()     memoryPeek() migrate()     name()     reboot()     ref()     resume()  ...