Skip to main content

FAMPP - FreeBSD, Apache, MySQL, PHP, PhpMyAdmin

FAMPP adalah idea daripada (FreeBSD,Apache,MySQL,PHP,PhpMyAdmin) , Tutorial ini akan membangunkan basic web server bersama-sama FreeBSD 7.2


FreeBSD 7.2 : Install Apache2.2

Ada dua cara untuk install aplikasi di FreeBSD
- ports
- pre-compiled pakej

kali ini kita akan gunakan cara yang mudah iaitu menggunakan pre-compiled pakej

#pkg_add -r apache22

edit /etc/rc.conf to start apache at boot

apache22_enable="YES"

Reboot and try to start.

#apachectl -k start

if got error something like this :

Syntax error on line 151 of /usr/local/etc/apache22/ht
tpd.conf:
DocumentRoot must be a directory

Edit your httpd.conf and make sure your folder "data" is created in /usr/local/www/apache22/

Try to start again,

#apachectl -k start

if got warning something like this :

[Mon Jan 01 08:31:17 2007] [warn] (2)No such file or directory: Failed to enable the 'httpready' Accept Filter

It is because some module are not loaded for filtering the packet

Load it as temporarily :

#kldload accf_http

or you want to load it at boot up edit the loader.conf

#ee /boot/loader.conf

add this line

accf_http_load="YES"

reboot :)

then try start apache service. it should be start normally without error :)


Some note for apachectl command :

# apachectl start
# apachectl restart
# apachectl graceful
# apachectl stop
# apachectl configtest

Configuration file :
/usr/local/etc/apache22/httpd.conf

Comments

Popular posts from this blog

Building a KVM Proxy

Traditionally we seldomly connect our KVM from the port directly to the server that consists of usb for keyboard and mouse, vga cable for display purposes. More advanced you may have an experience using the iKVM which connect all you kvm port from the internet where you can have a remote location as long as you have the internet connection. When technology evolve, physical server are becoming obsolete since we have the virtualization technology. Since that to access your virtual machine (vm) are more easier. Instead of using SSH, like a Xen hypervisor, the Xen itself can host as a KVM server and map to the vm on different port as configured from the config file.

Warning Nuffnanger's!

Dear Nuffnangers, As you might already know, there are 2 different types of campaigns from Nuffnang: Metered (mCPM) Campaigns , which pay according to the number of visitors who see the ads; and Cost-Per-Click (CPC) campaigns, which pay bloggers based on the number of clicks generated on the ads. It has come to our attention that certain groups have been committing click fraud, which is defined as clicking on CPC advertisements intentionally just to generate earnings for a blog's owner. Do note that this act is an abuse of our Terms & Conditions under Section 6. Banner ads are only supposed to be clicked on if the viewer is interested to find out more about the advertising campaign, and not for the intention of earning extra money. Should this situation worsen, the frequency of ad campaigns might be significantly reduced as we'll only be able to sell ad spaces on blogs with no click fraud record. Our system is capable of tracking these illegal actions...

Python - Xen and libvirt

more function can be found in python dir libvirtclass.txt shell> find / -name libvirtclass.txt Generated Classes for libvir-python # # Global functions of the module # # functions from module libvirt open() openReadOnly() virEventRegisterImpl() virInitialize() # functions from module virterror virGetLastError() virResetLastError() # # Set of classes of the module # Class virDomain()     # functions from module libvirt     ID()     OSType()     XMLDesc()     attachDevice()     blockPeek()     connect()     coreDump()     create()     destroy()     detachDevice()     maxMemory()     maxVcpus()     memoryPeek() migrate()     name()     reboot()     ref()     resume()  ...